+ Reply to Thread
Results 1 to 2 of 2

Thread: Webclient running very slow timeout errors messages and cannot delete email

  1. #1

    Thumbs up Webclient running very slow timeout errors messages and cannot delete email

    We recently spent a few weeks troubleshooting a horribly slow webclient v10.3.5 that caused the red error to pop up and say that the network connection dropped etc. Also if you tried to delete email it would hang the entire browser for 60 seconds, then not delete. Did this in Firefox 12 or IE9. We found the problem and figured I could save some poor sap a bunch of calls from their frustrated clients.

    Two buried settings that can bring teh webclient to it's knees, one is in the API console File-> API Console -> search for webservice.appmaxthreads was 10 on ours, upped to 40 or more. Otherwise it stops responding to new users in webclient at 10 and they have to wait for an open thread. A bit of an Achilles heal. And the other setting is a fastcgi php (assuming you are running fastcgi ang not ISAPI which is default) it's hidden in /config/webserver.dat <FCGI_THREADPOOL>40</FCGI_THREADPOOL> which was also 10. Again causing users hang and wait for open threads. We also upped fasccgi init to 15 which sucks up ram but if you have plenty to spare it runs a hell of a lot better. Then restart services. Set your web service logging to debug and it will show you how many threads are available, in use, and how many users are waiting. This completely solved our slow down.

    Our server has dual quad cores so 8 cores and 16GB ram x64 2008R2, setting these really high on a 2003 box that can only address 4GB ram should be tested first, in our case we weren't even using the hardware at 5% of it's capability due to icewarp limiting it. Which is probably to protect slower machines from hanging.

    Hope this helps someone else.

  2. #2
    Good, thanks for sharing. If its a very old install, its always good to compare webserver.dat with a fresh installation of latest version, as it might have some outdated tags and settings (between OPTIONS and /OPTIONS).

+ Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts